Redistribute - EIGRP -BGP

Topology:










Configuration and Output:


!
hostname R1
!
interface Loopback0
ip address 30.30.30.30 255.255.255.255
!
interface Ethernet0/1
ip address 192.168.1.101 255.255.255.0
duplex full
no shut
!
router eigrp 100
network 30.0.0.0
network 192.168.1.0
no auto-summary
!
end

!
hostname R2
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
ip address 20.20.20.20 255.255.255.255
!
interface Ethernet0/1
ip address 192.168.1.100 255.255.255.0
duplex full
no shut
!
interface Ethernet0/2
ip address 172.16.100.50 255.255.255.0
duplex full
no shut

!
router eigrp 100
redistribute static
redistribute bgp 1000 metric 100 1 255 1 1500
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
router bgp 1000
no synchronization
bgp log-neighbor-changes
network 20.20.20.20 mask 255.255.255.255
redistribute connected
redistribute static
redistribute eigrp 100
neighbor 172.16.100.51 remote-as 2000
neighbor 172.16.100.51 next-hop-self
no auto-summary
!
end

!
hostname R3
!
interface Loopback0
ip address 22.22.22.22 255.255.255.255

!
interface Ethernet0/2
ip address 172.16.100.51 255.255.255.0
duplex full
no shut
!
router bgp 2000
no synchronization
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
network 172.16.100.0 mask 255.255.255.0
neighbor 172.16.100.50 remote-as 1000
neighbor 172.16.100.50 default-originate
default-information originate
no auto-summary

!
end

Before Redistribute:


R1#show ip eigrp neighbors 
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.100           Et0/1             14 00:02:44   67   402  0  2
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/32 is subnetted, 1 subnets
D       10.10.10.10 [90/409600] via 192.168.1.100, 00:02:46, Ethernet0/1
C    192.168.1.0/24 is directly connected, Ethernet0/1
R1#show ip route eigrp
     10.0.0.0/32 is subnetted, 1 subnets
D       10.10.10.10 [90/409600] via 192.168.1.100, 00:02:55, Ethernet0/1
R1#


R2#show ip eigrp neig  
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.101           Et0/1             10 00:05:58   68   408  0  3
R2#show ip bgp summary 
BGP router identifier 20.20.20.20, local AS number 1000
BGP table version is 6, main routing table version 6
4 network entries using 468 bytes of memory
4 path entries using 208 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1072 total bytes of memory
BGP activity 4/0 prefixes, 4/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.100.51   4  2000       9       8        6    0    0 00:03:17        3
R2#show ip route       
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.100.51 to network 0.0.0.0

     20.0.0.0/32 is subnetted, 1 subnets
C       20.20.20.20 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.100.0 is directly connected, Ethernet0/2
     22.0.0.0/32 is subnetted, 1 subnets
B       22.22.22.22 [20/0] via 172.16.100.51, 00:03:24
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.10 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Ethernet0/1
B*   0.0.0.0/0 [20/0] via 172.16.100.51, 00:03:25
R2#show ip route eigrp 

R2#


R3#show ip bgp summary 
BGP router identifier 22.22.22.22, local AS number 2000
BGP table version is 4, main routing table version 4
3 network entries using 351 bytes of memory
3 path entries using 156 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 903 total bytes of memory
BGP activity 3/0 prefixes, 3/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.100.50   4  1000       9      10        4    0    0 00:04:03        1
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/32 is subnetted, 1 subnets
B       20.20.20.20 [20/0] via 172.16.100.50, 00:04:10
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.100.0 is directly connected, Ethernet0/2
     22.0.0.0/32 is subnetted, 1 subnets
C       22.22.22.22 is directly connected, Loopback0
R3#


After Redistribution:


R2(config-router)#redistribute bgp ?           
  <1-65535>  Autonomous system number

R2(config-router)#redistribute bgp 1000 ?
  metric     Metric for redistributed routes
  route-map  Route map reference
  <cr>

R2(config-router)#redistribute bgp 1000 met
R2(config-router)#redistribute bgp 1000 metric ?
  <1-4294967295>  Bandwidth metric in Kbits per second

R2(config-router)#redistribute bgp 1000 metric 100 ?
  <0-4294967295>  EIGRP delay metric, in 10 microsecond units

R2(config-router)#redistribute bgp 1000 metric 100 1 ?
  <0-255>  EIGRP reliability metric where 255 is 100% reliable

R2(config-router)#redistribute bgp 1000 metric 100 1 255 ?
  <1-255>  EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded

R2(config-router)#redistribute bgp 1000 metric 100 1 255 1 ?
  <1-65535>  EIGRP MTU of the path 

R2(config-router)#redistribute bgp 1000 metric 100 1 255 1 1400
R2(config-router)#exit
R2(config)#router bgp 1000
R2(config-router)#redistribute ei
R2(config-router)#redistribute eigrp ?  
  <1-65535>  Autonomous system number

R2(config-router)#redistribute eigrp 100
R2(config-router)#^Z


Output:

R1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.100 to network 0.0.0.0

     20.0.0.0/32 is subnetted, 1 subnets
D EX    20.20.20.20 [170/25625856] via 192.168.1.100, 00:02:27, Ethernet0/1
     22.0.0.0/32 is subnetted, 1 subnets
D EX    22.22.22.22 [170/25625856] via 192.168.1.100, 00:02:27, Ethernet0/1
     10.0.0.0/32 is subnetted, 1 subnets
D       10.10.10.10 [90/409600] via 192.168.1.100, 00:14:38, Ethernet0/1
C    192.168.1.0/24 is directly connected, Ethernet0/1
D*EX 0.0.0.0/0 [170/25625856] via 192.168.1.100, 00:02:27, Ethernet0/1
R1#

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.100.51 to network 0.0.0.0

     20.0.0.0/32 is subnetted, 1 subnets
C       20.20.20.20 is directly connected, Loopback1
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.100.0 is directly connected, Ethernet0/2
     22.0.0.0/32 is subnetted, 1 subnets
B       22.22.22.22 [20/0] via 172.16.100.51, 00:14:39
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.10 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Ethernet0/1
B*   0.0.0.0/0 [20/0] via 172.16.100.51, 00:14:39
R2#


R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/32 is subnetted, 1 subnets
B       20.20.20.20 [20/0] via 172.16.100.50, 00:14:30
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.100.0 is directly connected, Ethernet0/2
     22.0.0.0/32 is subnetted, 1 subnets
C       22.22.22.22 is directly connected, Loopback0
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.100.50, 00:02:17
B    192.168.1.0/24 [20/0] via 172.16.100.50, 00:02:17

R3#

No comments:

Post a Comment