DMVPN-Simple Topology with Configuration

Network Topology:


Configuration:

Interface Configuration:
R1:

!
hostname R1
!
interface GigabitEthernet1/0
ip address 10.0.0.1 255.255.255.0
no shutdown
!
R2:

!
hostname R2
!
interface GigabitEthernet2/0
ip address 10.0.0.2 255.255.255.0
no shutdown
!
R3:

!
hostname R3
!
interface GigabitEthernet3/0
ip address 10.0.0.3 255.255.255.0
no shutdown
!


Tunnel & DMVPN Configuration:

R1 (HUB):
!
interface Tunnel0
ip address 192.168.0.1 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp network-id 100
tunnel source GigabitEthernet1/0
tunnel mode gre multipoint
tunnel key 100
!

R2 (Spoke-1):
!
interface Tunnel0
ip address 192.168.0.2 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast 10.0.0.1
ip nhrp map 192.168.0.1 10.0.0.1
ip nhrp network-id 100
ip nhrp nhs 192.168.0.1
tunnel source GigabitEthernet2/0
tunnel mode gre multipoint
tunnel key 100
!  
R3 (Spoke-2):
!
interface Tunnel0
ip address 192.168.0.3 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast 10.0.0.1
ip nhrp map 192.168.0.1 10.0.0.1
ip nhrp network-id 100
ip nhrp nhs 192.168.0.1
tunnel source GigabitEthernet3/0
tunnel mode gre multipoint
tunnel key 100
!

The ip nhrp authentication command is used to allow the authenticated updates and queries to the NHRP Database, ensuring unwanted queries are not provided with any information about the DMVPN network.

The ip nhrp map multicast dynamic command enables the forwarding of multicast traffic across the tunnel to dynamic spokes. This is usually required by routing protocols such as OSPF and EIGRP.  In most cases, DMVPN is accompanied by a routing protocol to send and receive dynamic updates about the private networks.

The ip nhrp network-id 100 command is used to identify this DMVPN cloud. All routers participating in this DMVPN cloud must have the same network-id configured in order for tunnels to form between them.

The ip nhrp map multicast 10.0.0.1 ensures multicast traffic is sent only from spokes to the hub and not from spoke to spoke. All multicast traffic should be received by the hub, processed and then updates are sent out to the spokes.

the ip nhrp map 192.168.0.1 10.0.0.1 command maps the NHS address (192.168.0.1) to the Hub’s (R1) public IP address (10.0.0.1).


The ip nhrp nhs 192.168.0.1 command tells our spoke router who the Next Hop Server (NHS).



Output:

R1:

R1#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
       N - NATed, L - Local, X - No Socket
       # Ent --> Number of NHRP entries with same NBMA peer
       NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
       UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Hub, NHRP Peers:2, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 10.0.0.2            192.168.0.2    UP 00:00:44     D
     1 10.0.0.3            192.168.0.3    UP 00:00:28     D

R1#show ip nhrp
192.168.0.2/32 via 192.168.0.2
   Tunnel0 created 00:00:53, expire 01:59:06
   Type: dynamic, Flags: unique registered used 
   NBMA address: 10.0.0.2 
192.168.0.3/32 via 192.168.0.3
   Tunnel0 created 00:00:37, expire 01:59:22
   Type: dynamic, Flags: unique registered used 
   NBMA address: 10.0.0.3 
R1#

R2:
R2#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
       N - NATed, L - Local, X - No Socket
       # Ent --> Number of NHRP entries with same NBMA peer
       NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
       UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:1, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 10.0.0.1            192.168.0.1    UP 00:01:15     S

R2#show ip nhrp
192.168.0.1/32 via 192.168.0.1
   Tunnel0 created 00:01:19, never expire 
   Type: static, Flags: used 
   NBMA address: 10.0.0.1 
R2#

R3:
R3#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
       N - NATed, L - Local, X - No Socket
       # Ent --> Number of NHRP entries with same NBMA peer
       NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
       UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:1, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 10.0.0.1            192.168.0.1    UP 00:01:22     S

R3#show ip nhrp
192.168.0.1/32 via 192.168.0.1
   Tunnel0 created 00:01:25, never expire 
   Type: static, Flags: used 
   NBMA address: 10.0.0.1 
R3#

Initiate Ping to the tunnel ip between R2 & R3 and Check the output:

R2:
R2#ping 192.168.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/68/124 ms
R2#show dmvpn      
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
       N - NATed, L - Local, X - No Socket
       # Ent --> Number of NHRP entries with same NBMA peer
       NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
       UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:2, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 10.0.0.1            192.168.0.1    UP 00:02:34     S
     1 10.0.0.3            192.168.0.3    UP 00:00:00     D

R2#show ip nhrp    
192.168.0.1/32 via 192.168.0.1
   Tunnel0 created 00:02:38, never expire 
   Type: static, Flags: used 
   NBMA address: 10.0.0.1 
192.168.0.3/32 via 192.168.0.3
   Tunnel0 created 00:00:04, expire 01:59:56
   Type: dynamic, Flags: router 
   NBMA address: 10.0.0.3 
R2#

R3:
R3#show dmvpn  
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
       N - NATed, L - Local, X - No Socket
       # Ent --> Number of NHRP entries with same NBMA peer
       NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
       UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:2, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 10.0.0.1            192.168.0.1    UP 00:02:41     S
     1 10.0.0.2            192.168.0.2    UP 00:00:20     D

R3#show ip nhrp
192.168.0.1/32 via 192.168.0.1
   Tunnel0 created 00:02:43, never expire 
   Type: static, Flags: used 
   NBMA address: 10.0.0.1 
192.168.0.2/32 via 192.168.0.2
   Tunnel0 created 00:00:21, expire 01:59:40
   Type: dynamic, Flags: router implicit used 
   NBMA address: 10.0.0.2 
192.168.0.3/32 via 192.168.0.3
   Tunnel0 created 00:00:21, expire 01:59:40
   Type: dynamic, Flags: router unique local 
   NBMA address: 10.0.0.3 
    (no-socket) 

R3#

No comments:

Post a Comment